Manifest Incorrect

Discussion of bugs in GS-Base
Post Reply
martyn
Posts: 20
Joined: Thu Dec 29, 2011 5:14 pm

Manifest Incorrect

Post by martyn »

Just downloaded latest version.

Now I cannot open a file. I had copied some records from a table to another, then deleted the first table. I get 'Manifest not present or correct' dialogue......
Help, please!

Martyn
User avatar
citadel5
Posts: 224
Joined: Tue Apr 20, 2010 11:58 pm

Re: Manifest Incorrect

Post by citadel5 »

The bug was fixed and the file was updated (9.0.5) a few minutes ago. (Unless there is something else undetected concerning your case.)

If there are two tables and one of their names is the prefix of the 2nd one and if both those tables use binary fields (images or memo text) then deleting one of them leaves those memo entries names on the list in the "manifest.txt" file in the database zip archive.

(If this happen, a saved file have to be fixed manually by removing those names from that list. This can be easily done by right-clicking and opening such a zip and simply removing from that list those names which are out of order with their internal names.)
martyn
Posts: 20
Joined: Thu Dec 29, 2011 5:14 pm

Re: Manifest Incorrect

Post by martyn »

Yet again, thanks
Martyn
martyn
Posts: 20
Joined: Thu Dec 29, 2011 5:14 pm

Re: Manifest Incorrect

Post by martyn »

Still a problem, I'am afraid. After deleting the table and saving the manifest.txt file is corrupted + contains jibberish when openned to edit.
Regards
Martyn
User avatar
citadel5
Posts: 224
Joined: Tue Apr 20, 2010 11:58 pm

Re: Manifest Incorrect

Post by citadel5 »

Could you please e-mail any such (possibly small) database that after deleting the table(s) causes such problems? (Or - if it's not possible - the details description concerning what the structure of the database is.)
Haven't been able to reproduce it so far.
martyn
Posts: 20
Joined: Thu Dec 29, 2011 5:14 pm

Re: Manifest Incorrect

Post by martyn »

Just sent you a file.
Martyn
User avatar
citadel5
Posts: 224
Joined: Tue Apr 20, 2010 11:58 pm

Re: Manifest Incorrect

Post by citadel5 »

Thanks.
The bugs were fixed recently. The details were posted in the "GS-Base Updates" forum:
http://forum-en.citadel5.com/viewtopic.php?f=12&t=255
Post Reply